Lifove Story

우분투에서 Gradle 사용시 Error:(32, 13) Failed to resolve 본문

Lifove Programming

우분투에서 Gradle 사용시 Error:(32, 13) Failed to resolve

Lifove 2016.04.19 22:47

Android Studio에 import한 프로젝트를 gradle로 build 할 때, 아래와 같은 에러가 발생하는 경우가 있다.


Error:(32, 13) Failed to resolve: com.afollestad.material-dialogs:core:0.8.1.0


가능한 원인으로는,

(1) 사용하려는 외부 라이브러리가 저장된 Repository 서버 연결 설정이 잘못 됐거나

(2) 서버가 죽었거나

(3) https 연결을 위한  certificate이 맞지 않아서 발생됐을 가능성이다.


나의 경우는, 안드로이드 관련 외부 모듈을 사용하려고 해서, https://jitpack.io/ repository를 사용했는데 (https://jitpack.io/#afollestad/material-dialogs/0.8.5.4) 그 곳에 나온데로 설정도 하고, 서버에도 문제가 없는데도 계속 동일한 에러가 발생했다. 외부 모듈의 버전 문제이가 싶어서 버전 번호도 바꾸고, gradle버전도 변경해 보고 해도, 문제가 해결되지 않았다.


우분투가 아닌 Mac에서는 문제 없이 Build가 잘 되었다. 그래서 우분투와 문제가 연결됐나 싶어 계속 검색 중 다음의 정보를 찾게 되었다. http://stackoverflow.com/questions/26675814/gradle-could-not-head-https-pom-peer-not-authenticated 맨 마지막 댓글에 Java 8을 설치하라는 것...근본 원인은 java version에 따라 certificate 처리하는게 좀 다른 것 같다. (https://github.com/jitpack/jitpack.io/issues/423)


우분투에서 Java 8을 설치하는 방법은 아래를 참조하면 된다.

(1) OpenJDK 8: http://ubuntuhandbook.org/index.php/2015/01/install-openjdk-8-ubuntu-14-04-12-04-lts/

(2) Oracle Java 8: http://www.webupd8.org/2012/09/install-oracle-java-8-in-ubuntu-via-ppa.html


설치 후, Android Studio에서 File > Project Structure... > JDK location을 Java 8이 설치된 경로로 변경해 주고, Build하면 된다.



혹시 위의 방법으로도 해결이 안되면, 다음을 참조해서 certificate설정을 제대로 해보자. https://justus.berlin/2015/01/connection-problems-with-ssltls-peers-in-java-on-ubuntu-server-14-12-with-fix/ 


글이 도움이 되셨다면, 공감을 눌러주세요!


0 Comments
댓글쓰기 폼